<!DOCTYPE html>
<html lang="en-gb" >
<head>
		        	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=2.0">
	    <base href="https://www.observer.ug/news/headlines/62592-uganda-airlines-completes-maiden-flight-to-mombasa" />
	<meta http-equiv="content-type" content="text/html; charset=utf-8" />
	<meta name="keywords" content="uganda airlines, mombasa" />
	<meta name="author" content="URN" />
	<meta property="og:title" content="Uganda Airlines completes maiden flight to Mombasa " />
	<meta property="og:type" content="article" />
	<meta property="og:url" content="https://www.observer.ug/news/headlines/62592-uganda-airlines-completes-maiden-flight-to-mombasa" />
	<meta property="og:image" content="https://www.observer.ug/images2/companies/ugandairlines/Inside-Uganda-Airlines-flight-to-Mombasa.jpg" />
	<meta property="og:site_name" content="The Observer - Uganda" />
	<meta name="description" content="Uganda Airlines" />
	<title>Uganda Airlines completes maiden flight to Mombasa </title>
	<link href="/component/jcomments/feed/com_content/62592" rel="alternate" type="application/rss+xml" title="Uganda Airlines completes maiden flight to Mombasa" />
	<link href="https://www.observer.ug/templates/gk_news2/images/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
	<link href="/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
	<link href="https://www.observer.ug/component/search/?Itemid=306&amp;catid=111&amp;id=62592&amp;format=opensearch" rel="search" title="Search The Observer - Uganda" type="application/opensearchdescription+xml" />
	<link href="/index.php?option=com_ajax&plugin=arktypography&format=json" rel="stylesheet" type="text/css" />
	<link href="/components/com_jcomments/tpl/default/style.css?v=3002" rel="stylesheet" type="text/css" />
	<link href="https://www.observer.ug/plugins/content/addtoany/addtoany.css" rel="stylesheet" type="text/css" />
	<link href="/media/system/css/modal.css?fefd037331750a2ddb28608787b6535f" rel="stylesheet" type="text/css" />
	<link href="https://www.observer.ug/templates/gk_news2/css/font-awesome.css" rel="stylesheet" type="text/css" />
	<link href="https://www.observer.ug/templates/gk_news2/css/normalize.css" rel="stylesheet" type="text/css" />
	<link href="https://www.observer.ug/templates/gk_news2/css/layout.css" rel="stylesheet" type="text/css" />
	<link href="https://www.observer.ug/templates/gk_news2/css/joomla.css" rel="stylesheet" type="text/css" />
	<link href="https://www.observer.ug/templates/gk_news2/css/system/system.css" rel="stylesheet" type="text/css" />
	<link href="https://www.observer.ug/templates/gk_news2/css/template.css" rel="stylesheet" type="text/css" />
	<link href="https://www.observer.ug/templates/gk_news2/css/menu/menu.css" rel="stylesheet" type="text/css" />
	<link href="https://www.observer.ug/templates/gk_news2/css/gk.stuff.css" rel="stylesheet" type="text/css" />
	<link href="https://www.observer.ug/templates/gk_news2/css/style3.css" rel="stylesheet" type="text/css" />
	<link href="https://www.observer.ug/templates/gk_news2/css/typography/typography.style3.css" rel="stylesheet" type="text/css" />
	<link href="//fonts.googleapis.com/css?family=Bitter:400,700" rel="stylesheet" type="text/css" />
	<style type="text/css">
.childcontent .gkcol { width: 170px; }h1,h2,
.gkPopupWrap h3,
article header ul,
.nspHeader,
.gkwTemp,
#gkSearch #mod-search-searchword,
.box.highlights .nspInfo,
.box.highlights .nspText,
.gkNspPM-VideoList h3,
#ezblog-body.forFeatured > #ezblog-label,
.blog-read header .blog-brief,
#ezblog-body .archive-list.for-search li h3 a { font-family: 'Bitter', Arial, sans-serif; }
h3,h4,h5,h6,
body,
body button,
button,
.button,
input.button,
span.button,
button.button,
div.button,
input[type="submit"],
input[type="button"],
.pagenav-prev a,
.pagenav-next a,
.readon,
#gkMainbody .itemReadMore,
#gkMainbody .readmore > a,
.button.invert:active,
.button.invert:focus,
.button.invert:hover,
#gkUpdates,
#gkMainMenu,
.gkMenu > ul li div.childcontent li,
#gkLogo.text,
#system-message,
#gkMenuOverlayHeader,
#gkMenuOverlayContent,
.nspMain.nsp-list .nspHeader,
.items-more > h2

 { font-family: Arial, Helvetica, sans-serif; }
.blank { font-family: Arial, Helvetica, sans-serif; }
.blank { font-family: Arial, Helvetica, sans-serif; }
#gkSidebarRight { width: 28%; }
#gkSearch { width: 28%; }
#gkHighlights { width: 50.75%; }
#gkContent { background-image: none!important; }#gkPageContent { width: 100%; }
#gkPageContent > div { width: 72%; }
#gkContent { width: 100%; }
.gkPage { max-width: 1410px; }
#gkContentWrap > div { width: 100%; }
#menu123 > div,
#menu123 > div > .childcontent-inner { width: 170px; }
#menu348 > div,
#menu348 > div > .childcontent-inner { width: 170px; }
#menu84 > div,
#menu84 > div > .childcontent-inner { width: 170px; }
#gkHighlighterGK5-0 .gkHighlighterInterface span.text { color: #282828; } #gkHighlighterGK5-0 .gkHighlighterInterface { background-color: #001965; border-radius: 0px; -moz-border-radius: 0px; -webkit-border-radius: 0px; }
	</style>
	<script type="application/json" class="joomla-script-options new">{"csrf.token":"a4e46126b33c51a0f763c6ece95b3236","system.paths":{"root":"","base":""}}</script>
	<script src="/components/com_jcomments/js/jcomments-v2.3.js?v=12" type="text/javascript"></script>
	<script src="/components/com_jcomments/libraries/joomlatune/ajax.js?v=4" type="text/javascript"></script>
	<script src="//static.addtoany.com/menu/page.js" type="text/javascript" async="async"></script>
	<script src="/media/jui/js/jquery.min.js?fefd037331750a2ddb28608787b6535f" type="text/javascript"></script>
	<script src="/media/jui/js/jquery-noconflict.js?fefd037331750a2ddb28608787b6535f" type="text/javascript"></script>
	<script src="/media/jui/js/jquery-migrate.min.js?fefd037331750a2ddb28608787b6535f" type="text/javascript"></script>
	<script src="/media/jui/js/bootstrap.min.js?fefd037331750a2ddb28608787b6535f" type="text/javascript"></script>
	<script src="/media/system/js/mootools-core.js?fefd037331750a2ddb28608787b6535f" type="text/javascript"></script>
	<script src="/media/system/js/core.js?fefd037331750a2ddb28608787b6535f" type="text/javascript"></script>
	<script src="/media/system/js/mootools-more.js?fefd037331750a2ddb28608787b6535f" type="text/javascript"></script>
	<script src="/media/system/js/modal.js?fefd037331750a2ddb28608787b6535f" type="text/javascript"></script>
	<script src="https://www.observer.ug/templates/gk_news2/js/modernizr.js" type="text/javascript"></script>
	<script src="https://www.observer.ug/templates/gk_news2/js/gk.scripts.js" type="text/javascript"></script>
	<script src="https://www.observer.ug/templates/gk_news2/js/gk.menu.js" type="text/javascript"></script>
	<script src="https://www.observer.ug/modules/mod_highlighter_gk5/interface/scripts/jquery.easing.js" type="text/javascript"></script>
	<script src="https://www.observer.ug/modules/mod_highlighter_gk5/interface/scripts/engine.jquery.js" type="text/javascript"></script>
	<script type="text/javascript">

		jQuery(function($) {
			SqueezeBox.initialize({});
			SqueezeBox.assign($('a.modal').get(), {
				parse: 'rel'
			});
		});

		window.jModalClose = function () {
			SqueezeBox.close();
		};
		
		// Add extra modal close functionality for tinyMCE-based editors
		document.onreadystatechange = function () {
			if (document.readyState == 'interactive' && typeof tinyMCE != 'undefined' && tinyMCE)
			{
				if (typeof window.jModalClose_no_tinyMCE === 'undefined')
				{	
					window.jModalClose_no_tinyMCE = typeof(jModalClose) == 'function'  ?  jModalClose  :  false;
					
					jModalClose = function () {
						if (window.jModalClose_no_tinyMCE) window.jModalClose_no_tinyMCE.apply(this, arguments);
						tinyMCE.activeEditor.windowManager.close();
					};
				}
		
				if (typeof window.SqueezeBoxClose_no_tinyMCE === 'undefined')
				{
					if (typeof(SqueezeBox) == 'undefined')  SqueezeBox = {};
					window.SqueezeBoxClose_no_tinyMCE = typeof(SqueezeBox.close) == 'function'  ?  SqueezeBox.close  :  false;
		
					SqueezeBox.close = function () {
						if (window.SqueezeBoxClose_no_tinyMCE)  window.SqueezeBoxClose_no_tinyMCE.apply(this, arguments);
						tinyMCE.activeEditor.windowManager.close();
					};
				}
			}
		};
		
 $GKMenu = { height:true, width:false, duration: 250 };
$GK_TMPL_URL = "https://www.observer.ug/templates/gk_news2";

$GK_URL = "https://www.observer.ug/";

	</script>
	<meta property="twitter:card" content="summary_large_image" />
	<meta property="twitter:site" content="@observerug" />
	<meta property="twitter:title" content="Uganda Airlines completes maiden flight to Mombasa " />
	<meta property="article:tag" content="uganda airlines" />
	<meta property="article:tag" content="mombasa" />
	<meta property="og:image" content="https://www.observer.ug/images2/companies/ugandairlines/Inside-Uganda-Airlines-flight-to-Mombasa.jpg" />
	<meta property="twitter:image" content="https://www.observer.ug/images2/companies/ugandairlines/Inside-Uganda-Airlines-flight-to-Mombasa.jpg" />
	<link rel="apple-touch-icon" href="https://www.observer.ug/images2/companies/ugandairlines/Inside-Uganda-Airlines-flight-to-Mombasa.jpg">
	<meta property="og:description" content="Uganda Airlines" />
	<meta property="twitter:description" content="Uganda Airlines" />
	<meta property="fb:app_id" content="126188390735364" />
	<link rel="apple-touch-icon" href="https://www.observer.ug/templates/gk_news2/images/touch-device.png">
	<link rel="apple-touch-icon-precomposed" href="https://www.observer.ug/templates/gk_news2/images/touch-device.png">

    <link rel="stylesheet" href="https://www.observer.ug/templates/gk_news2/css/small.desktop.css" media="(max-width: 1410px)" />
<link rel="stylesheet" href="https://www.observer.ug/templates/gk_news2/css/tablet.css" media="(max-width: 1100px)" />
<link rel="stylesheet" href="https://www.observer.ug/templates/gk_news2/css/small.tablet.css" media="(max-width: 840px)" />
<link rel="stylesheet" href="https://www.observer.ug/templates/gk_news2/css/mobile.css" media="(max-width: 640px)" />
<link rel="stylesheet" href="https://www.observer.ug/templates/gk_news2/css/override.css" />

<!--[if IE 9]>
<link rel="stylesheet" href="https://www.observer.ug/templates/gk_news2/css/ie/ie9.css" type="text/css" />
<![endif]-->

<!--[if IE 8]>
<link rel="stylesheet" href="https://www.observer.ug/templates/gk_news2/css/ie/ie8.css" type="text/css" />
<![endif]-->

<!--[if lte IE 7]>
<link rel="stylesheet" href="https://www.observer.ug/templates/gk_news2/css/ie/ie7.css" type="text/css" />
<![endif]-->

<!--[if lte IE 9]>
<script type="text/javascript" src="https://www.observer.ug/templates/gk_news2/js/ie.js"></script>
<![endif]-->

<!--[if (gte IE 6)&(lte IE 8)]>
<script type="text/javascript" src="https://www.observer.ug/templates/gk_news2/js/respond.js"></script>
<script type="text/javascript" src="https://www.observer.ug/templates/gk_news2/js/html5shiv.js"></script>
<![endif]-->

<!--G SENSE AUTO FFK-->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-1435360256358138",
          enable_page_level_ads: true
     });
</script>

	 </head><body data-mobile="true" data-tablet-width="1100" data-tablet-small-width="840" data-mobile-width="640" data-smoothscroll="0">	
	<script type="text/javascript">var _gaq = _gaq || []; _gaq.push(['_setAccount', 'UA-32667704-1']); _gaq.push(['_trackPageview']);(function() { var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s); })();</script>		
		
	<div id="gkBg" class="gkPage">
		<div id="gkTopBar" data-menu-type="classic">
		    

          <a href="https://www.observer.ug/" id="gkLogo" class="text">
		<span>The Observer</span>
		     </a>
     		    
		    	
		    <div id="gkBannerTop">
		    	<ins class='obs-mtn dcmads' style='display:inline-block;width:728px;height:90px'
    data-dcm-placement='N710826.1960903OBSERVER/B21698592.228792637'
    data-dcm-rendering-mode='script'
    data-dcm-https-only
    data-dcm-resettable-device-id=''
    data-dcm-app-id=''>
<script src='https://www.googletagservices.com/dcm/dcmads.js'></script>
</ins>   
		    </div>
		      
            
            
            
            

            
            
            
            
            
		    
		    <div id="gkTopNav">
								<div id="gkMainMenu" class="gkMenuClassic">
				        <nav id="gkExtraMenu" class="gkMenu">
<ul class="gkmenu level0"><li  class="first haschild active"><a href="https://www.observer.ug/"  class=" first haschild active" id="menu123"  >News</a><div class="childcontent">
<div class="childcontent-inner">
<div class="gkcol gkcol1  first"><ul class="gkmenu level1"><li  class="first active"><a href="/news/headlines"  class=" first active" id="menu306"  >Headlines</a></li></ul></div>
</div>
</div></li><li ><a href="/business"  id="menu68"  >Business</a></li><li ><a href="/education"  id="menu106"  >Education</a></li><li ><a href="/lifestyle"  id="menu70"  >Lifestyle</a></li><li ><a href="/viewpoint"  id="menu60"  >Viewpoint</a></li><li ><a href="/sports"  id="menu80"  >Sports</a></li><li  class="haschild"><a href="/topics"  class=" haschild" id="menu348"  >Topics</a><div class="childcontent">
<div class="childcontent-inner">
<div class="gkcol gkcol1  first"><ul class="gkmenu level1"><li  class="first"><a href="/topics/agelimit"  class=" first" id="menu347"  >Age Limit</a></li><li ><a href="/topics/ple"  id="menu354"  >PLE</a></li><li  class="last"><a href="/topics/uce"  class=" last" id="menu355"  >UCE</a></li></ul></div>
</div>
</div></li><li ><a href="/quiz"  id="menu345"  >Quiz</a></li><li  class="haschild"><a href="/search"  class=" haschild" id="menu84"  >Search</a><div class="childcontent">
<div class="childcontent-inner">
<div class="gkcol gkcol1  first"><ul class="gkmenu level1"><li  class="first"><a href="/search/use-site-search"  class=" first" id="menu327"  >Use site search</a></li><li  class="last"><a href="/search/use-google"  class=" last" id="menu328"  >Use Google</a></li></ul></div>
</div>
</div></li><li  class="last"><a href="/contact-us"  class=" last" id="menu109"  >Contacts</a></li></ul>
</nav>				</div>                
										
				<div id="gkMobileMenu" class="gkPage"> 
					<i id="mobile-menu-toggler" class="fa fa-bars"></i>
				   	<select id="mobileMenu" onChange="window.location.href=this.value;" class="chzn-done">
				       <option  value="https://www.observer.ug/">News</option><option selected="selected"  value="/news/headlines">&mdash; Headlines</option><option  value="/business">Business</option><option  value="/education">Education</option><option  value="/lifestyle">Lifestyle</option><option  value="/viewpoint">Viewpoint</option><option  value="/sports">Sports</option><option  value="/topics">Topics</option><option  value="/topics/agelimit">&mdash; Age Limit</option><option  value="/topics/ple">&mdash; PLE</option><option  value="/topics/uce">&mdash; UCE</option><option  value="/quiz">Quiz</option><option  value="/search">Search</option><option  value="/search/use-site-search">&mdash; Use site search</option><option  value="/search/use-google">&mdash; Use Google</option><option  value="/contact-us">Contacts</option> 
				   	</select> 
              </div>
			     
			     			     			        	<a href="/index.php/component/users/?view=login&amp;tmpl=blankpage" id="gkLogin">
		        		Log in		        	</a>
		        			         		         
		         	
		         <div id="gkSocial">

		         	

<div class="custom "  >

	<a href="https://twitter.com/observerug" target="_blank"><i class="gk-icon-twitter"></i></a>
<a href="https://www.facebook.com/ugandaobserver" target="_blank"><i class="gk-icon-fb"></i></a>
<a href="https://observer.ug/headlinenews?format=feed&type=rss" target="_blank"><i class="gk-icon-rss"></i></a>		
</div>

		         </div>
		           
			 </div>
			 
			 			 <div id="gkToolbar">
			 		
			 	<div id="gkUpdates">
			 		Updated an hour ago			 	</div>
			 	 
			 	
			 		
			 	<div id="gkHighlights">
			 		<div class="gkHighlighterGK5" id="gkHighlighterGK5-0" data-config="{'animationType':'slidesBottom','animationSpeed':'350','animationInterval':'5000','animationFun':'Fx.Transitions.linear','mouseover':'true'}">
        <div class="gkHighlighterInterface" data-pos="left">
                <span class="text">Most Popular:</span>
                    </div>
        <div class="gkHighlighterWrapper">
    	<div class="gkHighlighterWrapperSub">
                                                    	<div class="gkHighlighterItem"><span><a href="/education/62580-iuea-are-the-new-inter-university-debate-champions"><span>9 - IUEA wins inter-university debate </span></a></span></div>
                                                            	<div class="gkHighlighterItem"><span><a href="/news/headlines/62589-mbarara-kidnappers-demand-shs-6m-ransom"><span>8 - Mbarara kidnappers demand Shs 6m ransom </span></a></span></div>
                                                            	<div class="gkHighlighterItem"><span><a href="/news/headlines/62592-uganda-airlines-completes-maiden-flight-to-mombasa"><span>7 - Uganda Airlines completes maiden flight to Mombasa </span></a></span></div>
                                                            	<div class="gkHighlighterItem"><span><a href="/news/headlines/62588-invigilators-fail-to-turn-up-for-uace-exams"><span>6 - Invigilators fail to turn up for UACE exams</span></a></span></div>
                                                            	<div class="gkHighlighterItem"><span><a href="/businessnews/62585-gov-t-to-appoint-new-utl-administrator"><span>5 - Gov’t to appoint new UTL administrator </span></a></span></div>
                                                            	<div class="gkHighlighterItem"><span><a href="/news/headlines/62582-sudan-coalition-wants-bashir-turned-over-to-icc"><span>4 - Sudan coalition wants Bashir turned over to ICC</span></a></span></div>
                                                            	<div class="gkHighlighterItem"><span><a href="/news/headlines/62581-bishops-condemn-brutality-against-mak-students-besigye"><span>3 - Bishops condemn brutality against Mak students, Besigye</span></a></span></div>
                                                            	<div class="gkHighlighterItem"><span><a href="/news/headlines/62584-two-ugandan-smugglers-shot-dead-in-rwanda"><span>2 - Two Ugandan 'smugglers' shot dead in Rwanda</span></a></span></div>
                                                            	<div class="gkHighlighterItem"><span><a href="/news/headlines/62579-delays-in-signing-final-investment-decision-in-oil-explained"><span>1 - Delays in signing final investment decision in oil explained</span></a></span></div>
                                        </div>
    </div>
</div>

			 	</div>
			 				 	
			 		
			 	<div id="gkSearch">
			 		<form action="/news/headlines" method="post">
	<div class="search">
		<input name="searchword" id="mod-search-searchword" maxlength="200"  class="inputbox" type="text" size="20" placeholder="search..." />	<input type="hidden" name="task" value="search" />
	<input type="hidden" name="option" value="com_search" />
	<input type="hidden" name="Itemid" value="306" />
	</div>
</form>

			 	</div>
			 	   
			 </div>
			              
             
             
             
             
             
             
             
                                         
               <section id="gkLang">
    	<div class="gkPage">
         	<div id="theo-app" style="display:flex; flex-wrap:wrap; align-items: center; padding: 4px; color: white; background-color: #8c0cc1; line-height: normal; text-align: center; justify-content: center; font-weight:bold; font-size: 110%;"><div style="padding: 0px 5px 0px 0px; float: left;">
Free: The Observer Mobile App - Exclusive Content and Services</div><div style="float:left; display:flex; align-items:center; text-align:center"><div style="padding: 0px 8px 0px 0px; float:left;"><a href="https://play.google.com/store/apps/details?id=ug.theo.app.android5bb2e658258fd"><img style="width:100%; min-width: 150px; max-width:200px" src ="https://observer.ug/images2/Ads/Clients/observer/gplay.png"></a></div><div style="float:left;"><a href="https://itunes.apple.com/us/app/the-observer/id1439015522?ls=1&mt=8"><img style="width:100%; min-width: 150px; max-width:200px" src ="https://observer.ug/images2/Ads/Clients/observer/astore.png"></a></div></div>
</div>
         </div>
    </section>
                 
             
             
             
             
             
             
             
             
             
             
             
		</div>
	
		<div id="gkPageContent">	
	    	<div>
		    	<section id="gkContent">
										<div id="gkBanners" class="gkEqualColumns">
							
						<div id="gkBannerLeft">
					    	<div class="box  gkmod-2"><div class="content"><!-- BEGIN: Custom advanced (www.pluginaria.com) --><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Obs Resp3 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1435360256358138"
     data-ad-slot="7832481393"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script><!-- END: Custom advanced (www.pluginaria.com) --></div></div><!-- BEGIN: Custom advanced (www.pluginaria.com) --><a href="https://www.fortebet.ug/?pref_device=desktop&utm_source=observer_ug&utm_medium=leaderboardHP&utm_campaign=august_campaing#/app/live/preview">

<img src="/images2/Ads/Clients/fortebet/banner_728x90_10.gif" style="margin:auto; text-align:center;"></a>

<!-- END: Custom advanced (www.pluginaria.com) -->
					    </div>
						  
						
						    
					</div>
										
										
										
										
					<div id="gkContentWrap">
						<div>
							
								
							
							<section id="gkMainbody">
																	
<article class="item-page " itemscope itemtype="https://schema.org/Article">
		<meta itemprop="inLanguage" content="en-GB" />
                    
                    <header>
                                        <h1 itemprop="name">
                         Uganda Airlines completes maiden flight to Mombasa                     </h1>
                                                            <ul>
                                                           
                                                            <li><time datetime="2019-11-11T21:04:09+03:00" itemprop="datePublished">November 11, 2019</time></li>
                                                                                          <li class="createdby" itemprop="author" itemscope itemtype="https://schema.org/Person">
                                                                                                                                                                Written by <span itemprop="name">URN</span>                                                                      </li>
                                                                                </ul>
                              </header>
                    
        <div class="itemBodyWrap">
          <div class="itemBody gkHasAside">
          		          			<div class="img-fulltext-none"> <img
          				class="caption" title="Inside Uganda Airlines flight to Mombasa"          			
          				          					style="float:none"
          				          			 src="/images2/companies/ugandairlines/Inside-Uganda-Airlines-flight-to-Mombasa.jpg" alt="Inside Uganda Airlines flight to Mombasa" itemprop="image"/> 
                  <p class="img_caption"> Inside Uganda Airlines flight to Mombasa</p>
                  </div>
          			          
                                                                                                                        			
					<span itemprop="articleBody">
                    <div class="addtoany_container"><span class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.observer.ug/news/headlines/62592-uganda-airlines-completes-maiden-flight-to-mombasa" data-a2a-title="Uganda Airlines completes maiden flight to Mombasa ">
<div style="margin-bottom:5px";>
<a class="a2a_button_whatsapp"></a>
<a class="a2a_button_facebook"></a>
<a class="a2a_button_twitter"></a>
<a class="a2a_button_email"></a>
</div>
<a class="a2a_dd" href="https://www.addtoany.com/share"></a>
</span>
</div><p>Uganda Airlines on Monday successfully completed a maiden flight to Moi international airport at the Kenyan coast of Mombasa.</p><p>The flight UR 342 was fully boarded, the airline said. The flight took off at 11:30 am and landed in Mombasa slightly after 1:40 pm. The airline is running a promotional offer of between Shs 568,135 and Shs 770,000 for a return ticket. After the promotion, a return ticket will cost 1,044,067 for the economy and Shs 1,249,371 for business class.</p><p>Kenya Airways and RwandAir fly to Mombasa but both make a stop in Nairobi. The stop means passengers destined for Mombasa spend one extra hour on the way. With the stopover, the journey takes about 3 hours and 40 minutes but the direct flight takes two hours and 40 minutes.</p><div style='float:left;margin:px;'><div class="fids-adsinside">

</div></div><p>Innocent Kihika, one of the passengers, said: “We arrived safely in Mombasa and now enjoying the Kenyan hospitality at the Moi international airport.”</p><p></p>
 
<p>Mombasa is particularly an important destination for business people in Uganda. Three-quarters of goods destined for Uganda dock at Mombasa. Many business people fly there whenever their goods dock or have a problem to sort. The coast is also an important tourist destination for Ugandans.</p><p>Uganda Airlines direct flight to Mombasa will make easier for those who find it tedious to fly to Jomo Kenyatta international airport (JKIA) in Nairobi before connecting to Moi international airport in Mombasa.</p><p>Meanwhile, another boom in the airline’s business has been the Entebbe-Juba route, according to an official at the ministry of Works. Initially, according to the official, government and the airline management were reluctant to add the Juba route on the fear that it might not make money. </p><p>“The route is making money,” the official said. “South Sudanese like to fly to Kampala and the Uganda Airline is making it happen.”</p><p>The recent peace talks also saw many officials use the airline to Juba and to Entebbe last week for the talks between rebel Riek Machar and President Salva Kiir. Also, Uganda is set to receive two Airbuses in 2020 which are expected to see the airline take competition from regional routes to international ones, according to Uganda Civil Aviation Authority director-general Dr David Kakuba. </p><p>This will complete the cycle for the revival of the airline, whose first commercial flight took place on August 28.</p><div class="addtoany_container"><span class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.observer.ug/news/headlines/62592-uganda-airlines-completes-maiden-flight-to-mombasa" data-a2a-title="Uganda Airlines completes maiden flight to Mombasa ">
<div style="margin-bottom:5px";>
<a class="a2a_button_whatsapp"></a>
<a class="a2a_button_facebook"></a>
<a class="a2a_button_twitter"></a>
<a class="a2a_button_email"></a>
</div>
<a class="a2a_dd" href="https://www.addtoany.com/share"></a>
</span>
</div></p><!-- START: Obs END -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-1435360256358138"
     data-ad-slot="6076546597"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<!-- END: Obs END -->                    </span>
                                        
                                                                                          </div>
          
                    <aside class="itemAsideInfo"> 
              <ul>
          			<li id="gkSocialAPI">
          			  <a href="http://twitter.com/share" class="twitter-share-button" data-text="Uganda Airlines completes maiden flight to Mombasa " data-url=""  data-count="vertical" data-via="observerug" data-lang="en">Tweet</a>
          			  
          			  <fb:like href="https://www.observer.ug/news/headlines/62592-uganda-airlines-completes-maiden-flight-to-mombasa"  send="true" layout="box_count" show_faces="false" width="400" action="like" font="arial" colorscheme="light"></fb:like>
          			  
          			  <g:plusone  size="tall" data-href="https://www.observer.ug/news/headlines/62592-uganda-airlines-completes-maiden-flight-to-mombasa"></g:plusone>
          			  
          			  
          			  
          			</li>
          			            
          			          			
          			          			<li class="itemPrint">
          				<i class="gk-icon-print"></i>
          				<a href="/news/headlines/62592-uganda-airlines-completes-maiden-flight-to-mombasa?tmpl=component&amp;print=1" title="Print article < Uganda Airlines completes maiden flight to Mombasa  >" onclick="window.open(this.href,'win2','status=no,toolbar=no,scrollbars=yes,titlebar=no,menubar=no,resizable=yes,width=640,height=480,directories=no,location=no'); return false;" rel="nofollow">			<span class="icon-print" aria-hidden="true"></span>
		Print	</a>          			</li>
          			          			
          			          			<li class="itemEmail">		
          				<i class="gk-icon-email"></i>
          				<a href="/component/mailto/?tmpl=component&amp;template=gk_news2&amp;link=6bb6402e6d35018b0d45ae127b7c6a7a191791c6" title="Email this link to a friend" onclick="window.open(this.href,'win2','width=400,height=350,menubar=yes,resizable=yes'); return false;" rel="nofollow">			<span class="icon-envelope" aria-hidden="true"></span>
		Email	</a>	
          			</li>
          			          				
          			          			
          			         	  </ul>
          </aside>
                    
          
          
          
          </div>
          
          
          
                    
          <script type="text/javascript">
<!--
var jcomments=new JComments(62592, 'com_content','/component/jcomments/');
jcomments.setList('comments-list');
//-->
</script>
<div id="jc">
<div id="comments"></div>
<h4>Add comment</h4>
<div class="comments-policy">Please note:<br />
a) No abuse<br />
b) No slander<br />
c) No obscenities<br />
d) No incitement to hatred or violence</div>
<a id="addcomments" href="#addcomments"></a>
<form id="comments-form" name="comments-form" action="javascript:void(null);">
<p>
	<span>
		<input id="comments-form-name" type="text" name="name" value="" maxlength="20" size="22" tabindex="1" />
		<label for="comments-form-name">Name (required)</label>
	</span>
</p>
<p>
	<span>
		<input id="comments-form-email" type="text" name="email" value="" size="22" tabindex="2" />
		<label for="comments-form-email">E-mail (required, but will not display)</label>
	</span>
</p>
<p>
	<span>
		<textarea id="comments-form-comment" name="comment" cols="65" rows="8" tabindex="5"></textarea>
	</span>
</p>
<p>
	<span>
		<input class="checkbox" id="comments-form-subscribe" type="checkbox" name="subscribe" value="1" tabindex="5" />
		<label for="comments-form-subscribe">Notify me of follow-up comments</label><br />
	</span>
</p>
<p>
	<span>
		<img class="captcha" onclick="jcomments.clear('captcha');" id="comments-form-captcha-image" src="/component/jcomments/captcha/85596" width="121" height="60" alt="Security code" /><br />
		<span class="captcha" onclick="jcomments.clear('captcha');">Refresh</span><br />
		<input class="captcha" id="comments-form-captcha" type="text" name="captcha_refid" value="" size="5" tabindex="6" /><br />
	</span>
</p>
<div id="comments-form-buttons">
	<div class="btn" id="comments-form-send"><div><a href="#" tabindex="7" onclick="jcomments.saveComment();return false;" title="Send (Ctrl+Enter)">Send</a></div></div>
	<div class="btn" id="comments-form-cancel" style="display:none;"><div><a href="#" tabindex="8" onclick="return false;" title="Cancel">Cancel</a></div></div>
	<div style="clear:both;"></div>
</div>
<div>
	<input type="hidden" name="object_id" value="62592" />
	<input type="hidden" name="object_group" value="com_content" />
</div>
</form>
<script type="text/javascript">
<!--
function JCommentsInitializeForm()
{
	var jcEditor = new JCommentsEditor('comments-form-comment', true);
	jcEditor.addCounter(1000, '', ' symbols left', 'counter');
	jcomments.setForm(new JCommentsForm('comments-form', jcEditor));
}

setTimeout(JCommentsInitializeForm, 100);
//-->
</script>
</div> 
</article>

															</section>
							
													</div>
						
											</div>
		    	</section>
		    	
		    			    	<section id="gkBottom1">
		    		<div class="gkCols6 gkEqualColumns">
		    			<!-- BEGIN: Custom advanced (www.pluginaria.com) --><a href="https://www.betpawa.ug/" target="_blank"><img class="fkresp" src="/images2/Ads/Clients/Pawabet/Observer-760x500.jpg" alt="betPawa" /></a><!-- END: Custom advanced (www.pluginaria.com) -->
		    		</div>
		    	</section>
		    			    	
		    				</div>
						<aside id="gkSidebarRight">
				<div>
					<div class="box "><div class="content"><div class="bannergroup">


</div>
</div></div><div class="box  clear title-color1 obs-newslist obs-latest"><h3 class="header">Latest Stories</h3>	<div class="nspMain  clear title-color1 obs-newslist obs-latest" id="nsp-nsp-785" data-config="{
				'animation_speed': 400,
				'animation_interval': 5000,
				'animation_function': 'Fx.Transitions.Expo.easeIn',
				'news_column': 0,
				'news_rows': 0,
				'links_columns_amount': 1,
				'links_amount': 8
			}">		
				
		
				<div class="nspLinksWrap bottom" style="width:99.9%;">
			<div class="nspLinks" style="margin:0;">
								<div class="nspLinkScroll1">
					<div class="nspLinkScroll2 nspPages1">
																				<ul class="nspList active nspCol1">
														
							<li class="even"><a href="/news/headlines/62589-mbarara-kidnappers-demand-shs-6m-ransom" class="nspImageWrapper"  style="margin:0 30px 0 0;" target="_self"><img  class="nspImage" src="https://www.observer.ug/modules/mod_news_pro_gk5/cache/serve1.public_html.images2.crime.Kidnap---ropednsp-785_links.jpg" alt=""  style="width:54px;height:54px;" /></a><div><h4><a href="/news/headlines/62589-mbarara-kidnappers-demand-shs-6m-ransom" title="Mbarara kidnappers demand Shs 6m ransom " target="_self">Mbarara kidnappers demand Shs 6m ransom </a></h4><span class="gkfidsinfo"><span class="gkfidsdate"><i class="fa fa-clock-o" aria-hidden="true"></i>An hour ago</span><span class="gkfidscat"><i class="fa fa-folder-open-o" aria-hidden="true"></i><a href="/news/headlines">News</a></span></span></div></li>							
																											
							<li class="odd"><a href="/news/headlines/62588-invigilators-fail-to-turn-up-for-uace-exams" class="nspImageWrapper"  style="margin:0 30px 0 0;" target="_self"><img  class="nspImage" src="https://www.observer.ug/modules/mod_news_pro_gk5/cache/serve1.public_html.images2.education.secondary-schools.UACE-examsnsp-785_links.png" alt=""  style="width:54px;height:54px;" /></a><div><h4><a href="/news/headlines/62588-invigilators-fail-to-turn-up-for-uace-exams" title="Invigilators fail to turn up for UACE exams" target="_self">Invigilators fail to turn up for UACE exams</a></h4><span class="gkfidsinfo"><span class="gkfidsdate"><i class="fa fa-clock-o" aria-hidden="true"></i>Few hours ago</span><span class="gkfidscat"><i class="fa fa-folder-open-o" aria-hidden="true"></i><a href="/news/headlines">News</a></span></span></div></li>							
																											
							<li class="even"><a href="/businessnews/62585-gov-t-to-appoint-new-utl-administrator" class="nspImageWrapper"  style="margin:0 30px 0 0;" target="_self"><img  class="nspImage" src="https://www.observer.ug/modules/mod_news_pro_gk5/cache/serve1.public_html.images2.business.Uganda-telecom-officensp-785_links.jpg" alt=""  style="width:54px;height:54px;" /></a><div><h4><a href="/businessnews/62585-gov-t-to-appoint-new-utl-administrator" title="Gov’t to appoint new UTL administrator " target="_self">Gov’t to appoint new UTL administrator </a></h4><span class="gkfidsinfo"><span class="gkfidsdate"><i class="fa fa-clock-o" aria-hidden="true"></i>Today</span><span class="gkfidscat"><i class="fa fa-folder-open-o" aria-hidden="true"></i><a href="/businessnews">Business</a></span></span></div></li>							
																											
							<li class="odd"><a href="/news/headlines/62584-two-ugandan-smugglers-shot-dead-in-rwanda" class="nspImageWrapper"  style="margin:0 30px 0 0;" target="_self"><img  class="nspImage" src="https://www.observer.ug/modules/mod_news_pro_gk5/cache/serve1.public_html.images2.diplomacy.Ugandan-security-at-Mproro-bordernsp-785_links.png" alt=""  style="width:54px;height:54px;" /></a><div><h4><a href="/news/headlines/62584-two-ugandan-smugglers-shot-dead-in-rwanda" title="Two Ugandan 'smugglers' shot dead in Rwanda" target="_self">Two Ugandan 'smugglers' shot dead in Rwanda</a></h4><span class="gkfidsinfo"><span class="gkfidsdate"><i class="fa fa-clock-o" aria-hidden="true"></i>Today</span><span class="gkfidscat"><i class="fa fa-folder-open-o" aria-hidden="true"></i><a href="/news/headlines">News</a></span></span></div></li>							
																											
							<li class="even"><a href="/news/headlines/62582-sudan-coalition-wants-bashir-turned-over-to-icc" class="nspImageWrapper"  style="margin:0 30px 0 0;" target="_self"><img  class="nspImage" src="https://www.observer.ug/modules/mod_news_pro_gk5/cache/serve1.public_html.images2.global.Omar-al-Bashir-makes-a-speechnsp-785_links.png" alt=""  style="width:54px;height:54px;" /></a><div><h4><a href="/news/headlines/62582-sudan-coalition-wants-bashir-turned-over-to-icc" title="Sudan coalition wants Bashir turned over to ICC" target="_self">Sudan coalition wants Bashir turned over to ICC</a></h4><span class="gkfidsinfo"><span class="gkfidsdate"><i class="fa fa-clock-o" aria-hidden="true"></i>Today</span><span class="gkfidscat"><i class="fa fa-folder-open-o" aria-hidden="true"></i><a href="/news/headlines">News</a></span></span></div></li>							
																											
							<li class="odd"><a href="/news/headlines/62581-bishops-condemn-brutality-against-mak-students-besigye" class="nspImageWrapper"  style="margin:0 30px 0 0;" target="_self"><img  class="nspImage" src="https://www.observer.ug/modules/mod_news_pro_gk5/cache/serve1.public_html.images2.protests.Female-student-protestors-at-Makererensp-785_links.jpg" alt=""  style="width:54px;height:54px;" /></a><div><h4><a href="/news/headlines/62581-bishops-condemn-brutality-against-mak-students-besigye" title="Bishops condemn brutality against Mak students, Besigye" target="_self">Bishops condemn brutality against Mak students, Besigye</a></h4><span class="gkfidsinfo"><span class="gkfidsdate"><i class="fa fa-clock-o" aria-hidden="true"></i>Today</span><span class="gkfidscat"><i class="fa fa-folder-open-o" aria-hidden="true"></i><a href="/news/headlines">News</a></span></span></div></li>							
																											
							<li class="even"><a href="/education/62580-iuea-are-the-new-inter-university-debate-champions" class="nspImageWrapper"  style="margin:0 30px 0 0;" target="_self"><img  class="nspImage" src="https://www.observer.ug/modules/mod_news_pro_gk5/cache/serve1.public_html.images2.education.universities.Jacob-Oulanyah-hands-over-the-trophy-to-IUEAnsp-785_links.png" alt=""  style="width:54px;height:54px;" /></a><div><h4><a href="/education/62580-iuea-are-the-new-inter-university-debate-champions" title="IUEA wins inter-university debate " target="_self">IUEA wins inter-university debate </a></h4><span class="gkfidsinfo"><span class="gkfidsdate"><i class="fa fa-clock-o" aria-hidden="true"></i>Today</span><span class="gkfidscat"><i class="fa fa-folder-open-o" aria-hidden="true"></i><a href="/education">Education</a></span></span></div></li>							
																											
							<li class="odd"><a href="/news/headlines/62579-delays-in-signing-final-investment-decision-in-oil-explained" class="nspImageWrapper"  style="margin:0 30px 0 0;" target="_self"><img  class="nspImage" src="https://www.observer.ug/modules/mod_news_pro_gk5/cache/serve1.public_html.images2.business.oil.Ernest-Rubondonsp-785_links.png" alt=""  style="width:54px;height:54px;" /></a><div><h4><a href="/news/headlines/62579-delays-in-signing-final-investment-decision-in-oil-explained" title="Delays in signing final investment decision in oil explained" target="_self">Delays in signing final investment decision in oil explained</a></h4><span class="gkfidsinfo"><span class="gkfidsdate"><i class="fa fa-clock-o" aria-hidden="true"></i>Saturday</span><span class="gkfidscat"><i class="fa fa-folder-open-o" aria-hidden="true"></i><a href="/news/headlines">News</a></span></span></div></li>							
														</ul>
															
					</div>
					
									</div>	
					
				
					
			</div>
		</div>
				
			</div>
</div><!-- BEGIN: Custom advanced (www.pluginaria.com) --><a href="https://www.ntindaview.com" target="_blank"><img class="fkresp" src="/images/00/nva2.jpg" alt="Ntinda View Apartments" /></a><!-- END: Custom advanced (www.pluginaria.com) -->
				</div>
			</aside>
					</div>
		
		    </div>
    
        
        
        
   
   
   
   
   
   
   

   
   
   
   
   
    
    
<footer id="gkFooter">
     <div class="gkPage">
                    <div id="gkFooterArea">
                              <a href="#gkBg" id="gkBackToTop">Back to top</a>
                                        </div>
                                         
          <p id="gkCopyrights">
          &#9400; 2019 Observer Media Ltd          </p>
                                   </div>
</footer>
   	

<div id="gkfb-root"></div>
<script type="text/javascript">

//<![CDATA[
   	window.fbAsyncInit = function() {
		FB.init({ appId: '', 
			status: true, 
			cookie: true,
			xfbml: true,
			oauth: true
		});
   		    
	  		};
    //      
    jQuery(window).load(function() {
    	(function(){
    		if(!document.getElementById('fb-root')) {
    			var root = document.createElement('div');
    			root.id = 'fb-root';
    			document.getElementById('gkfb-root').appendChild(root);
    			var e = document.createElement('script');
    			e.src = document.location.protocol + '//connect.facebook.net/en_US/all.js';
    			e.async = true;
    			document.getElementById('fb-root').appendChild(e);
    		}  
    	})();
    });
    //]]>
</script>


<!-- +1 button -->

<script type="text/javascript">
  window.___gcfg = {
    lang: 'en-GB',
    parsetags: 'onload'
  };
</script>
<script src="//apis.google.com/js/platform.js"  async defer></script>


<!-- twitter -->
          <script type="text/javascript" src="//platform.twitter.com/widgets.js"></script>
     

<!-- Pinterest script --> 
   		
	
	<script>
	jQuery(document).ready(function(){
   		// Target your .container, .wrapper, .post, etc.
   		jQuery("body").fitVids();
	});
	</script>
</body>
</html>